iDocs Partial Outage
Incident Report for iDOCS Status
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 16:29 SAST
Update
We are continuing to investigate this issue.
Posted Oct 04, 2021 - 16:20 SAST
Update
We are continuing to investigate this issue.
Posted Oct 04, 2021 - 16:09 SAST
Investigating
We are currently investigating this issue.
Posted Oct 04, 2021 - 15:54 SAST
This incident affected: iDOCS Web.