Service Advisory - Company Function

Incident Report for iDOCS Status

Resolved

This incident has been resolved.
Posted Sep 01, 2025 - 07:35 SAST

Monitoring

Please be advised that our offices will be closed from 12:00 today due to a scheduled company function.

For any urgent matters requiring immediate assistance, kindly contact our support line at:
Teal: 087 654 5929

We thank you for your understanding and continued support.
Posted Aug 29, 2025 - 11:38 SAST
This incident affected: iDOCS Web.