iDocs Credit Check Outage
Incident Report for iDOCS Status
Resolved
This incident has been resolved.
Posted Oct 02, 2023 - 22:29 SAST
Investigating
We are currently investigating this issue.
Posted Oct 02, 2023 - 18:26 SAST
This incident affected: Credit Check Service.