Credit Check Outage
Incident Report for iDOCS Status
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 10:41 SAST
Investigating
We are currently investigating this issue.
Posted Feb 25, 2021 - 08:43 SAST
This incident affected: Credit Check Service.