iDocs Outage

Incident Report for iDOCS Status

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 08:07 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2025 - 10:59 SAST

Investigating

We are currently investigating this issue.
Posted Apr 16, 2025 - 10:55 SAST
This incident affected: iDOCS Web.