Credit Check Outage

Incident Report for iDOCS Status

Resolved

The credit check service is fully operational. No issues are currently reported.
Posted Jun 13, 2026 - 11:16 SAST

Monitoring

The credit check service has been restored and is now operating normally. Our team continues to monitor the service to ensure stability.
Thank you for your patience.
Posted Jun 13, 2026 - 09:55 SAST

Update

We are currently experiencing issues with our credit check service. Our technical team has identified the problem and is actively working on a fix. We will provide updates here as soon as the issue is resolved.
We apologize for any inconvenience this may cause.
Posted Jun 13, 2026 - 09:49 SAST

Investigating

We are currently investigating this issue.
Posted Jun 13, 2026 - 09:39 SAST
This incident affected: Credit Check Service.