iDocs SMS Down

Incident Report for iDOCS Status

Resolved

This incident has been resolved.
Posted Jul 15, 2024 - 10:19 SAST

Investigating

We are currently investigating this issue.
Posted Jul 15, 2024 - 09:42 SAST
This incident affected: iDOCS Web.