iDocs Partial Out
Incident Report for iDOCS Status
Resolved
This incident has been resolved.
Posted Jan 15, 2021 - 12:24 SAST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 15, 2021 - 11:41 SAST
Investigating
We are currently investigating this issue.
Posted Jan 15, 2021 - 11:40 SAST
This incident affected: iDOCS Web.