iDocs Partial Outage
Incident Report for iDOCS Status
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 13:39 SAST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 25, 2021 - 13:32 SAST
Investigating
We are currently investigating this issue.
Posted Feb 25, 2021 - 13:29 SAST
This incident affected: iDOCS Web.